Skip to content
8.7 High Exploited

CVE-2026-42271 BerriAI LiteLLM Command Injection Vulnerability

Active exploitation observed

· CISA KEV catalogue
Required action Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Ransomware campaigns Not observed so far
Weakness CWE-78, CWE-77

Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

Affected products and versions

Product Affected versions Fixed in
litellm 1.74 1.74.2 → < 1.83.7 1.83.7
Red Hat OpenShift AI 2.25 1781826406 earliest → < 1781826406 1781826406
Red Hat OpenShift AI 3.3 1782310008 earliest → < 1782310008 1782310008
Red Hat OpenShift AI 3.4 1781622627 earliest → < 1781622627 1781622627
Exploit Intelligence Versions not published
Red Hat Ansible Automation Platform 2 Versions not published
Red Hat OpenShift AI (RHOAI) Versions not published

References

Timeline

  1. Published
  2. Added to the KEV catalogue
  3. Last modified
The 40 CVEs of litellm →
Track this CVE