Skip to content
8.7 High

CVE-2026-41163 bubblewrap is a low-level unprivileged sandboxing tool

Description

bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.

Affected products and versions

Product Affected versions Fixed in
bubblewrap 0.11 0.11.0 → < 0.11.2 0.11.2
Red Hat Enterprise Linux 10 Versions not published
Red Hat Enterprise Linux 8 Versions not published
Red Hat Enterprise Linux 9 Versions not published
Red Hat OpenShift Container Platform 4 Versions not published
The 2 CVEs of bubblewrap →
Track this CVE