8.7
High
CVE-2026-35029 LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0, the /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to modify proxy configuration and environment variables, register custom pass-through endpoint handlers pointing to attacker-controlled Python code, achieving remote code execution, read arbitrary server files by setting UI_LOGO_PATH and fetching via /get_image, and take over other privileged accounts by overwriting UI_USERNAME and UI_PASSWORD environment variables. Fixed in v1.83.0.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| litellm 1.83 | earliest → < 1.83.0 | 1.83.0 |
| Red Hat Ansible Automation Platform 2.6 1777398576 | earliest → < 1777398576 | 1777398576 |
| Red Hat OpenShift AI 2.25 1781826406 | earliest → < 1781826406 | 1781826406 |
| Red Hat OpenShift AI 3.3 1782310008 | earliest → < 1782310008 | 1782310008 |
| Lightspeed Core | Versions not published | |
| Red Hat OpenShift AI (RHOAI) | Versions not published |
References
- github.com github.com
Timeline
- Published
- Last modified
Other CVEs of litellm
The 40 CVEs of litellm →
CVE-2026-114612
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format
9.9
Critical
CVE-2026-108575
A vulnerability has been found in BerriAI LiteLLM up to 1.94.0
5.3
Medium
CVE-2026-108574
A flaw has been found in BerriAI LiteLLM up to 1.95.0
5.3
Medium
CVE-2026-93355
LiteLLM contains a weak authentication vulnerability that allows an attacker holding a valid JWT from the configured…
7.6
High