Skip to content
Not rated

CVE-2026-33858 Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing…

Description

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.

Affected products and versions

Product Affected versions Fixed in
Apache Airflow 3.1 3.1.8 → < 3.2.0 3.2.0
The 153 CVEs of Apache Airflow →
Track this CVE