Skip to content
Not rated

CVE-2026-33558 Information exposure vulnerability has been identified in Apache Kafka

Description

Information exposure vulnerability has been identified in Apache Kafka. The NetworkClient component will output entire requests and responses information in the DEBUG log level in the logs. By default, the log level is set to INFO level. If the DEBUG level is enabled, the sensitive information will be exposed via the requests and responses output log. The entire lists of impacted requests and responses are: * AlterConfigsRequest * AlterUserScramCredentialsRequest * ExpireDelegationTokenRequest * IncrementalAlterConfigsRequest * RenewDelegationTokenRequest * SaslAuthenticateRequest * createDelegationTokenResponse * describeDelegationTokenResponse * SaslAuthenticateResponse This issue affects Apache Kafka: from any version supported the listed API above through v3.9.1, v4.0.0. We advise the Kafka users to upgrade to v3.9.2, v4.0.1, or later to avoid this vulnerability.

Affected products and versions

Product Affected versions Fixed in
Apache Kafka 4.0.0 No fix stated
Apache Kafka 0.11 0.11.0 → 3.9.1 No fix stated
Apache Kafka Clients 4.0.0 No fix stated
Apache Kafka Clients 0.11 0.11.0 → 3.9.1 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 23 CVEs of Apache Kafka →
Track this CVE