Not rated
CVE-2026-32794 Improper Certificate Validation vulnerability in Apache Airflow Provider for Databricks
Description
Improper Certificate Validation vulnerability in Apache Airflow Provider for Databricks. Provider code did not validate certificates for connections to Databricks back-end which could result in a man-of-a-middle attack that traffic is intercepted and manipulated or credentials exfiltrated w/o notice. This issue affects Apache Airflow Provider for Databricks: from 1.10.0 before 1.12.0. Users are recommended to upgrade to version 1.12.0, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Airflow Provider for Databricks 1.10 | 1.10.0 → < 1.12.0 | 1.12.0 |
References
- github.com github.com
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified