8.1
High
CVE-2026-30851 Caddy is an extensible server platform that uses TLS by default
Description
Caddy is an extensible server platform that uses TLS by default. From version 2.10.0 to before version 2.11.2, forward_auth copy_headers does not strip client-supplied headers, allowing identity injection and privilege escalation. This issue has been patched in version 2.11.2.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| caddy 2.10 | 2.10.0 → < 2.11.2 | 2.11.2 |
References
- github.com github.com
- github.com github.com
- github.com github.com
- github.com github.com
Timeline
- Published
- Last modified
Other CVEs of caddy
The 17 CVEs of caddy →
CVE-2026-55458
Caddy: RFC 7230 §6.1 compliance issue / Hop-by-hop headers that leak through
2.9
Low
CVE-2026-92700
Caddy is an extensible server platform that uses TLS by default
6.3
Medium
CVE-2026-92284
Caddy is an extensible server platform that uses TLS by default
6.9
Medium
CVE-2026-77281
Caddy is an extensible server platform that uses TLS by default
6.5
Medium