7.5
High
CVE-2026-2996 The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Improper Input…
Description
The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation in all versions up to, and including, 1.6.21. This is due to a logic flaw in the 'validate_cart_data' function. This makes it possible for unauthenticated attackers to bypass required paid addons and complete purchases at the base product price only, effectively stealing products by paying a fraction of the intended total. The vulnerability was partially patched in version 1.6.19.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Advanced Product Fields (Product Addons) for WooCommerce 1.6 | earliest → 1.6.21 | No fix stated |