Not rated
CVE-2026-24713 Improper Input Validation vulnerability in Apache IoTDB
Description
Improper Input Validation vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7. Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache IoTDB 2.0 | 2.0.0 → < 2.0.7 | 2.0.7 |
| Apache IoTDB 1.0 | 1.0.0 → < 1.3.7 | 1.3.7 |
References
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache IoTDB
The 28 CVEs of Apache IoTDB →
CVE-2026-59229
The Legacy Pipe receiver protocol (handshake / sendPipeData) uses a hardcoded SUPER_USER (root) identity when…
Not rated
CVE-2026-59562
Missing authentication for critical function vulnerability in Apache IoTDB
Not rated
CVE-2026-58663
An authentication bypass vulnerability exists in Apache IoTDB's Thrift RPC service This issue affects Apache IoTDB: from…
Not rated
CVE-2026-44630
Improper validation of length fields in the Apache IoTDB RPC service may allow a remote unauthenticated attacker to…
Not rated