Skip to content
5.3 Medium

CVE-2026-23981 An Improper Authorization vulnerability exists in Apache Superset allowing an authenticated user with permissions to…

Description

An Improper Authorization vulnerability exists in Apache Superset allowing an authenticated user with permissions to update charts to modify dashboards they do not own. When updating a chart's properties via the REST API, a user can provide a list of dashboard IDs (dashboards) to associate the chart with. The validation logic in the UpdateChartCommand failed to verify that the user had write permissions for the target dashboards specified in the request body. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Superset 0.0 0.0.0 → < 6.0.0 6.0.0

References

Timeline

  1. Published
  2. Last modified
The 65 CVEs of Apache Superset →
Track this CVE