5.4
Medium
CVE-2026-1927 The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to unauthorized access of data due…
Description
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the greenshift_app_pass_validation() function in all versions up to, and including, 12.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to retrieve global plugin settings including stored AI API keys and modify plugin settings, including the injection of arbitrary web scripts via the 'custom_css' value (stored XSS). NOTE: This vulnerability was partially patched in version 12.6.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Greenshift – animation and page builder blocks 12.6 | earliest → 12.6 | No fix stated |
Other CVEs of Greenshift – animation and page builder blocks
The 22 CVEs of Greenshift – animation and page builder blocks →
CVE-2026-119218
Greenshift <= 13.2.2 - Unauthenticated Stored DOM-Based Cross-Site Scripting via Comment Author URL via Interaction Layer attach-attribute to Counter data-prefix
5.4
Medium
CVE-2026-120520
Greenshift <= 13.2.2 - Unauthenticated Sensitive Information Exposure in Nested {{COOKIE:}} Placeholder via {{GET:}} Parameter
5.3
Medium
CVE-2026-107629
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site…
5.4
Medium
CVE-2026-107627
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site…
5.4
Medium