Skip to content
8.7 High

CVE-2026-15810 A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68,…

Description

A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.

Affected products and versions

Product Affected versions Fixed in
Looker 26.8 earliest → < 26.8.7 26.8.7
Looker 26.6 earliest → < 26.6.28 26.6.28
Looker 26.4 earliest → < 26.4.36 26.4.36
Looker 26.2 earliest → < 26.2.47 26.2.47
Looker 26.0 earliest → < 26.0.66 26.0.66
Looker 25.18 earliest → < 25.18.68 25.18.68
Looker 25.12 earliest → < 25.12.65 25.12.65
Looker 25.6 earliest → < 25.6.103 25.6.103
The 10 CVEs of Looker →
Track this CVE