Skip to content
5.5 Medium

CVE-2026-13769 Overly permissive file permissions in AWS CLI before 1.44.78 (v1) and 2.34.29 (v2) on Unix-like systems where the…

Description

Overly permissive file permissions in AWS CLI before 1.44.78 (v1) and 2.34.29 (v2) on Unix-like systems where the umask has not been configured to restrict file permissions (the default on most systems) may allow other local users on the same host to read credentials written by certain CLI subcommands (aws codeartifact login, aws iam create-virtual-mfa-device, aws deploy register). To remediate this issue, users should upgrade to AWS CLI 1.44.78 (v1) or 2.34.29 (v2) or later.

Affected products and versions

Product Affected versions Fixed in
AWS CLI 2.34 earliest → 2.34.28 No fix stated
AWS CLI 1.44 earliest → 1.44.77 No fix stated
Track this CVE