Skip to content
Not rated

CVE-2026-111959 Out-of-bounds read vulnerability in Apache Arrow Rust (`arrow` crate), from version 33.0.0 through to versions 57.3.1,…

Description

Out-of-bounds read vulnerability in Apache Arrow Rust (`arrow` crate), from version 33.0.0 through to versions 57.3.1, 58.4.0, 59.3.1 and 60.0.0. Improper validation of RunEndEncoded arrays in the ArrayData interface can allow reading data beyond the bounds of the child values array. Users are recommended to upgrade to versions 60.1.0, 59.3.2, 58.4.1, 57.3.2 which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Arrow Rust 60.0 60.0.0 → < 60.1.0 60.1.0
Apache Arrow Rust 59.0 59.0.0 → 59.3.1 No fix stated
Apache Arrow Rust 58.0 58.0.0 → 58.4.0 No fix stated
Apache Arrow Rust 33.0 33.0.0 → 57.3.1 No fix stated

References

Timeline

  1. Published
  2. Last modified
Track this CVE