7.5
High
CVE-2026-104020 Uncontrolled recursion in the Ion reader in Amazon Ion Python before 0.15.0 might allow a remote unauthenticated actor…
Description
Uncontrolled recursion in the Ion reader in Amazon Ion Python before 0.15.0 might allow a remote unauthenticated actor to crash the application using the library, resulting in a denial of service, via a crafted, deeply nested Ion value. To remediate this issue, users should upgrade to version 0.15.0 or later.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| ion-python 0.15 | earliest → < 0.15.0 | 0.15.0 |