Skip to content
Not rated

CVE-2025-66171 The CloudStack Backup plugin has an improper access logic in versions 4.21.0.0 and 4.22.0.0

Description

The CloudStack Backup plugin has an improper access logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and have access to specific APIs can create new VMs using backups of any other user of the environment. Backup plugin users using CloudStack 4.21.0.0+ are recommended to upgrade to CloudStack version 4.22.0.1, which fixes this issue.

Affected products and versions

Product Affected versions Fixed in
Apache CloudStack 4.21 4.21.0.0 → 4.22.0.0 No fix stated
The 51 CVEs of Apache CloudStack →
Track this CVE