Skip to content
Not rated

CVE-2025-60012 Malicious configuration can lead to unauthorized file access in Apache Livy

Description

Malicious configuration can lead to unauthorized file access in Apache Livy. This issue affects Apache Livy 0.7.0 and 0.8.0 when connecting to Apache Spark 3.1 or later. A request that includes a Spark configuration value supported from Apache Spark version 3.1 can lead to users gaining access to files they do not have permissions to. For the vulnerability to be exploitable, the user needs to have access to Apache Livy's REST or JDBC interface and be able to send requests with arbitrary Spark configuration values. Users are recommended to upgrade to version 0.9.0 or later, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Livy 0.7 0.7.0-incubating → < 0.9.0-incubating 0.9.0-incubating

References

Timeline

  1. Published
  2. Last modified
The 2 CVEs of Apache Livy →
Track this CVE