Skip to content
Not rated

CVE-2025-53689 Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an…

Description

Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.

Affected products and versions

Product Affected versions Fixed in
Apache Jackrabbit 2.23 2.23.0-beta → < 2.23.2-beta 2.23.2-beta
Apache Jackrabbit 2.22 2.22.0 → < 2.22.1 2.22.1
Apache Jackrabbit 2.20 2.20.0 → < 2.20.17 2.20.17
The 3 CVEs of Apache Jackrabbit →
Track this CVE