Skip to content
Not rated

CVE-2025-53506 Uncontrolled Resource Consumption vulnerability in Apache Tomcat if an HTTP/2 client did not acknowledge the initial…

Description

Uncontrolled Resource Consumption vulnerability in Apache Tomcat if an HTTP/2 client did not acknowledge the initial settings frame that reduces the maximum permitted concurrent streams. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Tomcat 11.0 11.0.0-M1 → 11.0.8 No fix stated
Apache Tomcat 10.1 10.1.0-M1 → 10.1.42 No fix stated
Apache Tomcat 10.0 10.0.0-M1 → 10.0.27 No fix stated
Apache Tomcat 9.0 9.0.0.M1 → 9.0.106 No fix stated
Apache Tomcat 8.5 8.5.0 → 8.5.100 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 141 CVEs of Apache Tomcat →
Track this CVE