8.8
High
CVE-2025-4919 An attacker was able to perform an out-of-bounds read or write on a JavaScript object by confusing array index sizes
Description
An attacker was able to perform an out-of-bounds read or write on a JavaScript object by confusing array index sizes. This vulnerability was fixed in Firefox 138.0.4, Firefox ESR 128.10.1, Firefox ESR 115.23.1, Thunderbird 128.10.2, and Thunderbird 138.0.2.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Firefox 138.0 | earliest → < 138.0.4 | 138.0.4 |
| Firefox 128.10 | earliest → < 128.10.1 | 128.10.1 |
| Firefox 115.23 | earliest → < 115.23.1 | 115.23.1 |
| Firefox ESR 115.23 | earliest → < 115.23.1 | 115.23.1 |
| Thunderbird 138.0 | earliest → < 138.0.2 | 138.0.2 |
| Thunderbird 128.10 | earliest → < 128.10.2 | 128.10.2 |