Skip to content
Not rated

CVE-2025-48924 Uncontrolled Recursion vulnerability in Apache Commons Lang

Description

Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Commons Lang 3.0 3.0 → < 3.18.0 3.18.0

References

Timeline

  1. Published
  2. Last modified
Track this CVE