Skip to content
6.0 Medium

CVE-2025-47436 Heap-based Buffer Overflow vulnerability in Apache ORC

Description

Heap-based Buffer Overflow vulnerability in Apache ORC. A vulnerability has been identified in the ORC C++ LZO decompression logic, where specially crafted malformed ORC files can cause the decompressor to allocate a 250-byte buffer but then attempts to copy 295 bytes into it. It causes memory corruption. This issue affects Apache ORC C++ library: through 1.8.8, from 1.9.0 through 1.9.5, from 2.0.0 through 2.0.4, from 2.1.0 through 2.1.1. Users are recommended to upgrade to version 1.8.9, 1.9.6, 2.0.5, and 2.1.2, which fix the issue.

Affected products and versions

Product Affected versions Fixed in
Apache ORC 2.1 2.1.0 → 2.1.1 No fix stated
Apache ORC 2.0 2.0.0 → 2.0.4 No fix stated
Apache ORC 1.9 1.9.0 → 1.9.5 No fix stated
Apache ORC 1.8 earliest → 1.8.8 No fix stated
The 2 CVEs of Apache ORC →
Track this CVE