Skip to content
Not rated

CVE-2025-46701 Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass…

Description

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Tomcat 11.0 11.0.0-M1 → 11.0.6 No fix stated
Apache Tomcat 10.1 10.1.0-M1 → 10.1.40 No fix stated
Apache Tomcat 10.0 10.0.0-M1 → 10.0.27 No fix stated
Apache Tomcat 9.0 9.0.0.M1 → 9.0.104 No fix stated
Apache Tomcat 8.5 8.5.0 → 8.5.100 No fix stated
Apache Tomcat 3 3 → < 8.5.0 8.5.0

References

Timeline

  1. Published
  2. Last modified
The 141 CVEs of Apache Tomcat →
Track this CVE