10.0
Critical
CVE-2025-32444 vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs
Description
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| vllm 0.6 | 0.6.5 → < 0.8.5 | 0.8.5 |
Other CVEs of vllm
The 121 CVEs of vllm →
CVE-2026-115918
vLLM is an inference and serving engine for large language models
6.5
Medium
CVE-2026-115917
vLLM is an inference and serving engine for large language models
3.4
Low
CVE-2026-115916
vLLM is an inference and serving engine for large language models
6.5
Medium
CVE-2026-115915
vLLM is an inference and serving engine for large language models
8.1
High