Skip to content
Not rated

CVE-2025-31650 Improper Input Validation vulnerability in Apache Tomcat

Description

Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Tomcat 11.0 11.0.0-M2 → 11.0.5 No fix stated
Apache Tomcat 10.1 10.1.10 → 10.1.39 No fix stated
Apache Tomcat 9.0 9.0.76 → 9.0.102 No fix stated
Apache Tomcat 8.5 8.5.90 → 8.5.100 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 141 CVEs of Apache Tomcat →
Track this CVE