Not rated
CVE-2025-30177 Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions
Description
Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions. This issue affects Apache Camel: from 4.10.0 before 4.10.3, from 4.8.0 before 4.8.6. Users are recommended to upgrade to version 4.10.3 for 4.10.x LTS and 4.8.6 for 4.8.x LTS. Camel undertow component is vulnerable to Camel message header injection, in particular the custom header filter strategy used by the component only filter the "out" direction, while it doesn't filter the "in" direction. This allows an attacker to include Camel specific headers that for some Camel components can alter the behaviour such as the camel-bean component, or the camel-exec component.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Camel 4.10 | 4.10.0 → < 4.10.3 | 4.10.3 |
| Apache Camel 4.8 | 4.8.0 → < 4.8.6 | 4.8.6 |
References
- camel.apache.org camel.apache.org
- camel.apache.org camel.apache.org
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache Camel
The 97 CVEs of Apache Camel →
CVE-2026-71569
Server-Side Request Forgery (SSRF) vulnerability in Apache Camel A2A component
4.8
Medium
CVE-2026-90885
Improper Restriction of XML External Entity Reference vulnerability in Apache Camel Saxon component
7.5
High
CVE-2026-94386
Use of Cache Containing Sensitive Information vulnerability in Apache Camel Oauth component
4.8
Medium
CVE-2026-95628
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Camel Docling…
5.4
Medium