Skip to content
Not rated

CVE-2025-27528 Deserialization of Untrusted Data vulnerability in Apache InLong

Description

Deserialization of Untrusted Data vulnerability in Apache InLong. This issue affects Apache InLong: from 1.13.0 through 2.1.0. This vulnerability allows attackers to bypass the security mechanisms of InLong JDBC and leads to arbitrary file reading. Users are advised to upgrade to Apache InLong's 2.2.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/11747

Affected products and versions

Product Affected versions Fixed in
Apache InLong 1.13 1.13.0 → 2.1.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 41 CVEs of Apache InLong →
Track this CVE