Skip to content
Not rated

CVE-2025-27446 Incorrect Permission Assignment for Critical Resource vulnerability in Apache APISIX(java-plugin-runner)

Description

Incorrect Permission Assignment for Critical Resource vulnerability in Apache APISIX(java-plugin-runner). Local listening file permissions in APISIX plugin runner allow a local attacker to elevate privileges. This issue affects Apache APISIX(java-plugin-runner): from 0.2.0 through 0.5.0. Users are recommended to upgrade to version 0.6.0 or higher, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache APISIX Java Plugin Runner 0.2 0.2.0 → 0.5.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
Track this CVE