Skip to content
7.8 High

CVE-2025-24274 An input validation issue was addressed by removing the vulnerable code

Description

An input validation issue was addressed by removing the vulnerable code. This issue is fixed in macOS Sequoia 15.5, macOS Sonoma 14.7.6, macOS Ventura 13.7.6. A malicious app may be able to gain root privileges.

Affected products and versions

Product Affected versions Fixed in
macOS 15.5 earliest → < 15.5 15.5
macOS 14.7 earliest → < 14.7.6 14.7.6
macOS 13.7 earliest → < 13.7.6 13.7.6
The 3813 CVEs of macOS →
Track this CVE