Skip to content
2.3 Low

CVE-2025-22829 The CloudStack Quota plugin has an improper privilege management logic in version 4.20.0.0

Description

The CloudStack Quota plugin has an improper privilege management logic in version 4.20.0.0. Anyone with authenticated user-account access in CloudStack 4.20.0.0 environments, where this plugin is enabled and have access to specific APIs can enable or disable reception of quota-related emails for any account in the environment and list their configurations. Quota plugin users using CloudStack 4.20.0.0 are recommended to upgrade to CloudStack version 4.20.1.0, which fixes this issue.

Affected products and versions

Product Affected versions Fixed in
Apache CloudStack 4.20 4.20.0.0 → < 4.20.1.0 4.20.1.0
The 51 CVEs of Apache CloudStack →
Track this CVE