Skip to content
6.4 Medium

CVE-2025-1802 The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the…

Description

The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘marker_title’, 'notification_content', and 'stt_button_text' parameters in all versions up to, and including, 2.8.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.8.3.

Affected products and versions

Product Affected versions Fixed in
HT Mega – Absolute Addons For Elementor 2.8 earliest → 2.8.3 No fix stated
HT Mega Addons for Elementor – Elementor Widgets & Template Builder 2.8 earliest → 2.8.3 No fix stated
The 24 CVEs of HT Mega – Absolute Addons For Elementor →
Track this CVE