Skip to content
6.5 Medium

CVE-2025-15033 A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on…

Description

A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.

Affected products and versions

Product Affected versions Fixed in
WoooCommerce 10.4 10.4.0 → < 10.4.3 10.4.3
WoooCommerce 10.3 10.3.0 → < 10.3.7 10.3.7
WoooCommerce 10.2 10.2.0 → < 10.2.3 10.2.3
WoooCommerce 10.1 10.1.0 → < 10.1.3 10.1.3
WoooCommerce 10.0 10.0.0 → < 10.0.5 10.0.5
WoooCommerce 9.9 9.9.0 → < 9.9.6 9.9.6
WoooCommerce 9.8 9.8.0 → < 9.8.6 9.8.6
WoooCommerce 9.7 9.7.0 → < 9.7.2 9.7.2
WoooCommerce 9.6 9.6.0 → < 9.6.3 9.6.3
Show the 39 other branches
Product Affected versions Fixed in
WoooCommerce 9.5 9.5.0 → < 9.5.3 9.5.3
WoooCommerce 9.4 9.4.0 → < 9.4.4 9.4.4
WoooCommerce 9.3 9.3.0 → < 9.3.5 9.3.5
WoooCommerce 9.2 9.2.0 → < 9.2.4 9.2.4
WoooCommerce 9.1 9.1.0 → < 9.1.5 9.1.5
WoooCommerce 9.0 9.0.0 → < 9.0.3 9.0.3
WoooCommerce 8.9 8.9.0 → < 8.9.4 8.9.4
WoooCommerce 8.8 8.8.0 → < 8.8.6 8.8.6
WoooCommerce 8.7 8.7.0 → < 8.7.2 8.7.2
WoooCommerce 8.6 8.6.0 → < 8.6.3 8.6.3
WoooCommerce 8.5 8.5.0 → < 8.5.4 8.5.4
WoooCommerce 8.4 8.4.0 → < 8.4.2 8.4.2
WoooCommerce 8.3 8.3.0 → < 8.3.3 8.3.3
WoooCommerce 8.2 8.2.0 → < 8.2.4 8.2.4
WoooCommerce 8.1 8.1.0 → < 8.1.3 8.1.3
WooCommerce 10.4 10.4.0 → < 10.4.3 10.4.3
WooCommerce 10.3 10.3.0 → < 10.3.7 10.3.7
WooCommerce 10.2 10.2.0 → < 10.2.3 10.2.3
WooCommerce 10.1 10.1.0 → < 10.1.3 10.1.3
WooCommerce 10.0 10.0.0 → < 10.0.5 10.0.5
WooCommerce 9.9 9.9.0 → < 9.9.6 9.9.6
WooCommerce 9.8 9.8.0 → < 9.8.6 9.8.6
WooCommerce 9.7 9.7.0 → < 9.7.2 9.7.2
WooCommerce 9.6 9.6.0 → < 9.6.3 9.6.3
WooCommerce 9.5 9.5.0 → < 9.5.3 9.5.3
WooCommerce 9.4 9.4.0 → < 9.4.4 9.4.4
WooCommerce 9.3 9.3.0 → < 9.3.5 9.3.5
WooCommerce 9.2 9.2.0 → < 9.2.4 9.2.4
WooCommerce 9.1 9.1.0 → < 9.1.5 9.1.5
WooCommerce 9.0 9.0.0 → < 9.0.3 9.0.3
WooCommerce 8.9 8.9.0 → < 8.9.4 8.9.4
WooCommerce 8.8 8.8.0 → < 8.8.6 8.8.6
WooCommerce 8.7 8.7.0 → < 8.7.2 8.7.2
WooCommerce 8.6 8.6.0 → < 8.6.3 8.6.3
WooCommerce 8.5 8.5.0 → < 8.5.4 8.5.4
WooCommerce 8.4 8.4.0 → < 8.4.2 8.4.2
WooCommerce 8.3 8.3.0 → < 8.3.3 8.3.3
WooCommerce 8.2 8.2.0 → < 8.2.4 8.2.4
WooCommerce 8.1 8.1.0 → < 8.1.3 8.1.3
Track this CVE