Skip to content
4.3 Medium

CVE-2025-12377 The Gallery Plugin for WordPress – Envira Photo Gallery plugin for WordPress is vulnerable to unauthorized…

Description

The Gallery Plugin for WordPress – Envira Photo Gallery plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several functions in all versions up to, and including, 1.12.0. This makes it possible for authenticated attackers, with Author-level access and above, to perform multiple actions, such as removing images from arbitrary galleries. The vulnerability was partially patched in version 1.12.0.

Affected products and versions

Product Affected versions Fixed in
Gallery Plugin for WordPress – Envira Photo Gallery 1.12 earliest → 1.12.0 No fix stated
Envira Gallery – Image Photo Gallery, Albums, Video Gallery, Slideshows & More 1.12 earliest → 1.12.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 4 CVEs of Gallery Plugin for WordPress – Envira Photo Gallery →
Track this CVE