Skip to content
7.5 High

CVE-2025-12044 Vault and Vault Enterprise (“Vault”) are vulnerable to an unauthenticated denial of service when processing JSON…

Description

Vault and Vault Enterprise (“Vault”) are vulnerable to an unauthenticated denial of service when processing JSON payloads. This occurs due to a regression from a previous fix for [+HCSEC-2025-24+|https://discuss.hashicorp.com/t/hcsec-2025-24-vault-denial-of-service-though-complex-json-payloads/76393]  which allowed for processing JSON payloads before applying rate limits. This vulnerability, CVE-2025-12044, is fixed in Vault Community Edition 1.21.0 and Vault Enterprise 1.16.27, 1.19.11, 1.20.5, and 1.21.0.

Affected products and versions

Product Affected versions Fixed in
Vault 1.20 1.20.3 → < 1.21.0 1.21.0
Vault Enterprise 1.20 1.20.3 → < 1.21.0 1.21.0
Vault Enterprise 1.19 1.19.9 → < 1.19.11 1.19.11
Vault Enterprise 1.18 1.18.14 → < 1.18.15 1.18.15
Vault Enterprise 1.16 1.16.25 → < 1.16.27 1.16.27
The 43 CVEs of Vault →
Track this CVE