Skip to content
6.5 Medium

CVE-2024-7514 The WordPress Comments Import & Export plugin for WordPress is vulnerable to to arbitrary file read due to…

Description

The WordPress Comments Import & Export plugin for WordPress is vulnerable to to arbitrary file read due to insufficient file path validation during the comments import process, in versions up to, and including, 2.3.7. This makes it possible for authenticated attackers, with Author-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information. The issue was partially fixed in version 2.3.8 and fully fixed in 2.3.9

Affected products and versions

Product Affected versions Fixed in
WordPress Comments Import & Export 2.3 earliest → 2.3.7 No fix stated
Comments Import & Export 2.3 earliest → 2.3.7 No fix stated
The 4 CVEs of WordPress Comments Import & Export →
Track this CVE