5.8
Medium
CVE-2024-56323 OpenFGA is an authorization/permission engine
Description
OpenFGA is an authorization/permission engine. IN OpenFGA v1.3.8 to v1.8.2 (Helm chart openfga-0.1.38 to openfga-0.2.19, docker v1.3.8 to v.1.8.2) are vulnerable to authorization bypass under the following conditions: 1. calling Check API or ListObjects with a model that uses [conditions](https://openfga.dev/docs/modeling/conditions), and 2. calling Check API or ListObjects API with [contextual tuples](https://openfga.dev/docs/concepts#what-are-contextual-tuples) that include conditions and 3. OpenFGA is configured with caching enabled (`OPENFGA_CHECK_QUERY_CACHE_ENABLED`). Users are advised to upgrade to v1.8.3. There are no known workarounds for this vulnerability.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| openfga 1.3 | 1.3.8 → < 1.8.3 | 1.8.3 |
Other CVEs of openfga
The 27 CVEs of openfga →
CVE-2026-61709
OpenFGA is an authorization and permission engine built for developers
5.3
Medium
CVE-2026-55689
OpenFGA is an authorization/permission engine built for developers
6.8
Medium
CVE-2026-55170
OpenFGA is an authorization/permission engine built for developers
2.1
Low
CVE-2026-48096
OpenFGA is an authorization/permission engine built for developers
5.0
Medium