Skip to content
8.0 High

CVE-2024-45693 Users logged into the Apache CloudStack's web interface can be tricked to submit malicious CSRF requests due to…

Description

Users logged into the Apache CloudStack's web interface can be tricked to submit malicious CSRF requests due to missing validation of the origin of the requests. This can allow an attacker to gain privileges and access to resources of the authenticated users and may lead to account takeover, disruption, exposure of sensitive data and compromise integrity of the resources owned by the user account that are managed by the platform. This issue affects Apache CloudStack from 4.15.1.0 through 4.18.2.3 and 4.19.0.0 through 4.19.1.1 Users are recommended to upgrade to Apache CloudStack 4.18.2.4 or 4.19.1.2, or later, which addresses this issue.

Affected products and versions

Product Affected versions Fixed in
Apache CloudStack 4.19 4.19.0.0 → 4.19.1.1 No fix stated
Apache CloudStack 4.15 4.15.1.0 → 4.18.2.3 No fix stated
cloudstack 4.19 4.19.0.0 → 4.19.1.1 No fix stated
cloudstack 4.15 4.15.1.0 → 4.18.2.3 No fix stated
The 51 CVEs of Apache CloudStack →
Track this CVE