Skip to content
9.9 Critical

CVE-2024-45387 An SQL injection vulnerability in Traffic Ops in Apache Traffic Control = 8.0.0 allows a privileged user with role…

Description

An SQL injection vulnerability in Traffic Ops in Apache Traffic Control <= 8.0.1, >= 8.0.0 allows a privileged user with role "admin", "federation", "operations", "portal", or "steering" to execute arbitrary SQL against the database by sending a specially-crafted PUT request. Users are recommended to upgrade to version Apache Traffic Control 8.0.2 if you run an affected version of Traffic Ops.

Affected products and versions

Product Affected versions Fixed in
Apache Traffic Control 8.0 8.0.0 → 8.0.1 No fix stated
Apache Traffic Control 7.0 earliest → < 7.0.0 7.0.0

References

Timeline

  1. Published
  2. Last modified
The 6 CVEs of Apache Traffic Control →
Track this CVE