Skip to content
Not rated

CVE-2024-39877 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler

Description

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

Affected products and versions

Product Affected versions Fixed in
Apache Airflow 2.4 2.4.0 → < 2.9.3 2.9.3
Airflow 2.4 2.4.0 → < 2.9.3 2.9.3

References

Timeline

  1. Published
  2. Last modified
The 153 CVEs of Apache Airflow →
Track this CVE