Skip to content
Not rated Exploited

CVE-2024-38856 Apache OFBiz Incorrect Authorization Vulnerability

Active exploitation observed

· CISA KEV catalogue
Required action Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Ransomware campaigns Not observed so far
Weakness CWE-863

Description

Incorrect Authorization vulnerability in Apache OFBiz. This issue affects Apache OFBiz: through 18.12.14. Users are recommended to upgrade to version 18.12.15, which fixes the issue. Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).

Affected products and versions

Product Affected versions Fixed in
Apache OFBiz 18.12 earliest → 18.12.14 No fix stated
OFBiz 18.12 earliest → 18.12.14 No fix stated

References

Timeline

  1. Published
  2. Added to the KEV catalogue
  3. Last modified
The 97 CVEs of Apache OFBiz →
Track this CVE