Skip to content
Not rated

CVE-2024-23114 Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is…

Description

Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Affected products and versions

Product Affected versions Fixed in
Apache Camel 4.1 4.1.0 → < 4.4.0 4.4.0
Apache Camel 4.0 4.0.0 → < 4.0.4 4.0.4
Apache Camel 3.22 3.22.0 → < 3.22.1 3.22.1
Apache Camel 3.0 3.0.0 → < 3.21.4 3.21.4
camel 4.1 4.1.0 → < 4.4.0 4.4.0
camel 4.0 4.0.0 → < 4.0.4 4.0.4
camel 3.22 3.22.0 → < 3.22.1 3.22.1
camel 3.0 3.0.0 → < 3.21.4 3.21.4

References

Timeline

  1. Published
  2. Last modified
The 97 CVEs of Apache Camel →
Track this CVE