Skip to content
2.9 Low

CVE-2024-22371 Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that…

Description

Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0. Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Camel 4.0 4.0.x → 4.0.3 No fix stated
Apache Camel 4 4.x → 4.3.0 No fix stated
Apache Camel 3.22 3.22.x → 3.22.0 No fix stated
Apache Camel 3.21 3.21.x → 3.21.3 No fix stated
Apache Camel 1 earliest → < 1.x 1.x
The 97 CVEs of Apache Camel →
Track this CVE