5.3
Medium
CVE-2024-14042 A vulnerability was found in Open5GS up to 2.7.1
Description
A vulnerability was found in Open5GS up to 2.7.1. This affects the function hss_ogs_diam_s6a_air_cb/hss_ogs_diam_s6a_ulr_cb of the file src/hss/hss-s6a-path.c of the component Diameter S6a Interface. Performing a manipulation of the argument os.len results in stack-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been made public and could be used. Upgrading to version 2.7.2 is able to mitigate this issue. The patch is named e89aa79efe629ae90f59dcdf8847c117d9a7da86. It is suggested to upgrade the affected component.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Open5GS 2.7 | 2.7.0 → 2.7.1 | 2.7.2 |
References
- VDB-387280 | Open5GS Diameter S6a hss-s6a-path.c hss_ogs_diam_s6a_ulr_cb stack-based overflow vuldb.com
- VDB-387280 | CTI Indicators (IOB, IOC, IOA) vuldb.com
- CVE-2024-14042 | CVE Analysis and Report vuldb.com
- Submit #867105 | Open5GS v2.7.2 Memory Corruption vuldb.com
- github.com github.com
- github.com github.com
- github.com github.com
- github.com github.com
- github.com github.com
Timeline
- Published
- Last modified
Other CVEs of Open5GS
The 125 CVEs of Open5GS →
CVE-2026-107166
A weakness has been identified in Open5GS up to 2.7.7
6.9
Medium
CVE-2026-92417
A vulnerability was found in Open5GS up to 2.8.0
7.1
High
CVE-2026-92416
A vulnerability has been found in Open5GS up to 2.8.0
5.3
Medium
CVE-2026-91855
A security flaw has been discovered in Open5GS up to 2.7.7
6.9
Medium