8.8
High
CVE-2023-5869 Postgresql: buffer overrun from integer overflow in array modification
Description
A flaw was found in PostgreSQL that allows authenticated database users to execute arbitrary code through missing overflow checks during SQL array value modification. This issue exists due to an integer overflow during array modification where a remote user can trigger the overflow by providing specially crafted data. This enables the execution of arbitrary code on the target system, allowing users to write arbitrary bytes to memory and extensively read the server's memory.
CVSS 3.1 detail
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitable remotely over the network, with an ordinary account and without any user action; an attacker can seriously compromise confidentiality, integrity or availability.
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- Interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Red Hat Advanced Cluster Security 4.2 4.2 | earliest → < 4.2.4-7 | 4.2.4-7 |
| Red Hat Enterprise Linux 7 | Versions not published | |
| Red Hat Enterprise Linux 8 | Versions not published | |
| Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions 8010020231130170510 | earliest → < 8010020231130170510.c27ad7f8 | 8010020231130170510.c27ad7f8 |
| Red Hat Enterprise Linux 8.2 Advanced Update Support 8020020231201202149.4 | earliest → < 8020020231201202149.4cda2c84 | 8020020231201202149.4cda2c84 |
| Red Hat Enterprise Linux 8.2 Telecommunications Update Service 8020020231201202149.4 | earliest → < 8020020231201202149.4cda2c84 | 8020020231201202149.4cda2c84 |
| Red Hat Enterprise Linux 8.2 Update Services for SAP Solutions 8020020231201202149.4 | earliest → < 8020020231201202149.4cda2c84 | 8020020231201202149.4cda2c84 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 8040020231127142440.522 | earliest → < 8040020231127142440.522a0ee4 | 8040020231127142440.522a0ee4 |
| Red Hat Enterprise Linux 8.4 Telecommunications Update Service 8040020231127142440.522 | earliest → < 8040020231127142440.522a0ee4 | 8040020231127142440.522a0ee4 |
Show the 10 other branches Hide the 10 other branches
| Product | Affected versions | Fixed in |
|---|---|---|
| Red Hat Enterprise Linux 8.4 Update Services for SAP Solutions 8040020231127142440.522 | earliest → < 8040020231127142440.522a0ee4 | 8040020231127142440.522a0ee4 |
| Red Hat Enterprise Linux 8.6 Extended Update Support 8060020231201202249 | earliest → < 8060020231201202249.ad008a3a | 8060020231201202249.ad008a3a |
| Red Hat Enterprise Linux 8.8 Extended Update Support 8080020231113134015.63 | earliest → < 8080020231113134015.63b34585 | 8080020231113134015.63b34585 |
| Red Hat Enterprise Linux 9 | Versions not published | |
| Red Hat Enterprise Linux 9.0 Extended Update Support | Versions not published | |
| Red Hat Enterprise Linux 9.2 Extended Update Support 9020020231115020618 | earliest → < 9020020231115020618.rhel9 | 9020020231115020618.rhel9 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | Versions not published | |
| RHACS-3.74-RHEL-8 3.74 | earliest → < 3.74.8-9 | 3.74.8-9 |
| RHACS-4.1-RHEL-8 4.1 | earliest → < 4.1.6-6 | 4.1.6-6 |
| Red Hat Enterprise Linux 6 | Versions not published |
Other CVEs of Red Hat Advanced Cluster Security 4.2
The 5 CVEs of Red Hat Advanced Cluster Security 4.2 →
CVE-2023-4958
In Red Hat Advanced Cluster Security (RHACS), it was found that some security related HTTP headers were missing,…
6.1
Medium
CVE-2023-5870
Postgresql: role pg_signal_backend can signal certain superuser processes.
2.2
Low
CVE-2023-5868
Postgresql: memory disclosure in aggregate function calls
4.3
Medium
CVE-2023-39417
Postgresql: extension script @substitutions@ within quoting allow sql injection
7.5
High