Skip to content
10.0 Critical Exploited · ransomware

CVE-2023-46604 Apache ActiveMQ Deserialization of Untrusted Data Vulnerability

Active exploitation observed

· CISA KEV catalogue
Required action Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Ransomware campaigns Known to be used
Weakness CWE-502

Description

The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.

Affected products and versions

Product Affected versions Fixed in
Apache ActiveMQ 5.18 5.18.0 → < 5.18.3 5.18.3
Apache ActiveMQ 5.17 5.17.0 → < 5.17.6 5.17.6
Apache ActiveMQ 5.16 5.16.0 → < 5.16.7 5.16.7
Apache ActiveMQ 5.15 earliest → < 5.15.16 5.15.16
Apache ActiveMQ Legacy OpenWire Module 5.18 5.18.0 → < 5.18.3 5.18.3
Apache ActiveMQ Legacy OpenWire Module 5.17 5.17.0 → < 5.17.6 5.17.6
Apache ActiveMQ Legacy OpenWire Module 5.16 5.16.0 → < 5.16.7 5.16.7
Apache ActiveMQ Legacy OpenWire Module 5.8 5.8.0 → < 5.15.16 5.15.16

References

Timeline

  1. Published
  2. Added to the KEV catalogue
  3. Last modified
The 40 CVEs of Apache ActiveMQ →
Track this CVE