Skip to content
Not rated

CVE-2023-46589 Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1…

Description

Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Tomcat 11.0 11.0.0-M1 → 11.0.0-M10 No fix stated
Apache Tomcat 10.1 10.1.0-M1 → 10.1.15 No fix stated
Apache Tomcat 10.0 10.0.0-M1 → 10.0.27 No fix stated
Apache Tomcat 9.0 9.0.0-M1 → 9.0.82 No fix stated
Apache Tomcat 8.5 8.5.0 → 8.5.95 No fix stated
Apache Tomcat 3 3 → < 8.5.0 8.5.0
Tomcat 11.0 11.0.0-m1 → 11.0.0-m10 No fix stated
Tomcat 10.1 10.1.0-M1 → 10.1.15 No fix stated
Tomcat 9.0 9.0.0-M1 → 9.0.82 No fix stated
Show the other branch
Product Affected versions Fixed in
Tomcat 8.5 8.5.0 → 8.5.95 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 141 CVEs of Apache Tomcat →
Track this CVE