Skip to content
6.5 Medium

CVE-2022-46258 An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a repository-scoped…

Description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a repository-scoped token with read/write access to modify Action Workflow files without a Workflow scope. The Create or Update file contents API should enforce workflow scope. This vulnerability affected all versions of GitHub Enterprise Server prior to version 3.7 and was fixed in versions 3.3.16, 3.4.11, 3.5.8, and 3.6.4. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products and versions

Product Affected versions Fixed in
GitHub Enterprise Server 3.6 3.6 → < 3.6.4 3.6.4
GitHub Enterprise Server 3.5 3.5 → < 3.5.8 3.5.8
GitHub Enterprise Server 3.4 3.4 → < 3.4.11 3.4.11
GitHub Enterprise Server 3.3 3.3 → < 3.3.16 3.3.16
The 46 CVEs of GitHub Enterprise Server →
Track this CVE