Not rated
CVE-2022-44645 In Apache…
Description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users to upgrade the version of Linkis to version 1.3.1.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Linkis (incubating) 1.3 | earliest → 1.3.0 | No fix stated |
References
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified