Skip to content
7.2 High

CVE-2022-23741 An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a scoped user-to-server…

Description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a scoped user-to-server token to escalate to full admin/owner privileges. An attacker would require an account with admin access to install a malicious GitHub App. This vulnerability was fixed in versions 3.3.17, 3.4.12, 3.5.9, and 3.6.5. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products and versions

Product Affected versions Fixed in
GitHub Enterprise Server 3.6 3.6 → < 3.6.5 3.6.5
GitHub Enterprise Server 3.5 3.5 → < 3.5.9 3.5.9
GitHub Enterprise Server 3.4 3.4 → < 3.4.12 3.4.12
GitHub Enterprise Server 3.3 3.3 → < 3.3.17 3.3.17
The 46 CVEs of GitHub Enterprise Server →
Track this CVE