Skip to content
8.8 High

CVE-2022-23740 CRITICAL: An improper neutralization of argument delimiters in a command vulnerability was identified in GitHub…

Description

CRITICAL: An improper neutralization of argument delimiters in a command vulnerability was identified in GitHub Enterprise Server that enabled remote code execution. To exploit this vulnerability, an attacker would need permission to create and build GitHub Pages using GitHub Actions. This vulnerability affected only version 3.7.0 of GitHub Enterprise Server and was fixed in version 3.7.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products and versions

Product Affected versions Fixed in
GitHub Enterprise Server 3.7 3.7 → < 3.7.1 3.7.1
The 46 CVEs of GitHub Enterprise Server →
Track this CVE